Announcement

Collapse
No announcement yet.

Cruise control

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Cruise control

    Help

    My 88 GW cruise was working just fine. Then....nothing.
    I've purchased a complete replacement on e-bay but everything seems to check out. Column function as all work. Cruise control module has peer to the various functions including servo. No blown fuses. What gives?
    Only thing not replaced is the column controls but they indicate good. My cruise control indicator on the dash was working but when the cruise quit so did the light. Any chance that could cause my problem. I hate to just give up.
    Thank you all.

  • #2
    Check the function and fuses for your brake light switch.
    -Jonny B.
    1979 Cherokee Golden Eagle - UNDER CONSTRUCTION
    7" Alcan springs, BJ's HD shackles - 35x12.5x15 BFG Mud Terrains
    AMC 401 - Pro-Flo 4 EFI
    NV4500/NWF BB/NP205 - Triple Stick'd
    F D44 - 4.10, Eaton E-Locker
    R M23 - 4.10, Detroit Locker

    1979 Cherokee Chief - Parts
    1979 Cherokee Chief - Parts
    1979 Wagoneer - Sold
    1981 Cherokee Chief - Cubed

    Comment


    • #3
      If your brake light bulb is out, cruise wont work.
      Member FSJ Prissy Restoration Association
      88 Grand Wagoneer
      360/727/NP208/dana 3.31s
      Edelbrock 2131
      Holley 600
      Hydroboost
      Hedman headers
      Dual exhaust
      MSD6A, TFI
      Digital Gauges
      Rusty's 2" Lift
      31x10.5 15LT15s
      Quote From Friend's Mom:
      "You don't rely on that vehicle do you?"

      Comment


      • #4
        Check for vacuum to the servo.
        Dave

        The few. The proud. The browless.

        Somewhere between prissy and pristene

        Comment


        • #5
          Check the tiny, 4 amp glass inline fuse -- hidden under the dash on the red wire going from the column to the brake pedal/brake light switch (wire may connect to/become a pink wire before the brake switch.

          Edited to correct earlier mistake -- I said 'column to cruise module.' There are three wires -- and two go to the module -- but this one goes to the brake pedal switch. Also clarified wire colors.
          Last edited by acct21; 09-15-2016, 08:31 AM.
          1990 Grand Wagoneer with HD towing package -- everything works! (for now...)

          Comment


          • #6
            Originally posted by acct21
            Check the tiny, 4 amp glass inline fuse -- hidden under the dash on the pink wire going from the column to the cruise module.
            x2 Both my GW's had blown fuses...and they are hidden. NOT in fuse panel for some dumb reason.
            Both worked fine after replacing this fuse.
            Tony
            88 GW, 67 J3000, 07 Magnum SRT8

            Comment


            • #7
              Originally posted by babywag
              x2 Both my GW's had blown fuses...and they are hidden. NOT in fuse panel for some dumb reason.
              Both worked fine after replacing this fuse.
              This is great to know. Wish I had seen then before putting the driver seat back in.
              Anyone have a photo?
              Current Jeep Fleet:
              1993 Wrangler Sahara (YJ) Stock, 52k
              1991 Grand Wagoneer - [Black] 4" Lift, 32's, 92k
              1991 Grand Wagoneer - [Hunter Green] Stock, 60k
              1991 Grand Wagoneer - [Hunter Green] Restored (for sale)
              ------------------------------------------------
              Four Wheel Trends

              Comment


              • #8
                Originally posted by asudchiman
                This is great to know. Wish I had seen then before putting the driver seat back in.
                Anyone have a photo?
                LOL. I had my seat fully back, as reclined as it goes, and was lying upside-down, on my back -- reaching over my head and under the dash. Had to open (and re-close) the inline fuse holder with one hand. I don't know if you could take a picture of the dang thing -- unless you pulled the entire cluster and dash.

                It looks just like this one -- push-in-and-twist to open it up.

                1990 Grand Wagoneer with HD towing package -- everything works! (for now...)

                Comment


                • #9
                  Originally posted by Fascination
                  Help

                  My cruise control indicator on the dash was working but when the cruise quit so did the light. Any chance that could cause my problem. I hate to just give up.
                  Thank you all.
                  We have a cruise control indicator light?

                  Ours works intermittently and when it does work it pumps the throttle like mad. Been meaning to look into it.
                  2004 Jeep Liberty
                  1998 Jeep ZJ 5.9
                  1994 Jeep ZJ I6
                  1989 Jeep Grand Wagoneer 360

                  Comment


                  • #10
                    Ours works intermittently and when it does work it pumps the throttle like mad. Been meaning to look into it.
                    I'd bet that is a vacuum leak between the vacuum ball and your servo.
                    1990 Grand Wagoneer with HD towing package -- everything works! (for now...)

                    Comment


                    • #11
                      Originally posted by acct21
                      LOL. I had my seat fully back, as reclined as it goes, and was lying upside-down, on my back -- reaching over my head and under the dash. Had to open (and re-close) the inline fuse holder with one hand. I don't know if you could take a picture of the dang thing -- unless you pulled the entire cluster and dash.

                      It looks just like this one -- push-in-and-twist to open it up.


                      Thanks. I was in the same position but with the seat out. Funny think is, for as many wires I traced I never saw an inline fuse . Guess I get to go on a hunt for it. My cruise is not working, and I am hoping it is something simple like a fuse.

                      Thanks
                      Current Jeep Fleet:
                      1993 Wrangler Sahara (YJ) Stock, 52k
                      1991 Grand Wagoneer - [Black] 4" Lift, 32's, 92k
                      1991 Grand Wagoneer - [Hunter Green] Stock, 60k
                      1991 Grand Wagoneer - [Hunter Green] Restored (for sale)
                      ------------------------------------------------
                      Four Wheel Trends

                      Comment


                      • #12
                        Funny think is, for as many wires I traced I never saw an inline fuse . Guess I get to go on a hunt for it. My cruise is not working, and I am hoping it is something simple like a fuse.
                        Trace a pink wire coming from the brake pedal switch (there may be two, but one will be headed toward the fuse block; you want the other one). It may go through a connector, and may turn into a red wire (in '87 it says 'red with white tracer'). It should be headed for the column loom, but in there is a small inline fuse holder. That 4A fuse is likely toast.
                        1990 Grand Wagoneer with HD towing package -- everything works! (for now...)

                        Comment


                        • #13




                          Last edited by Gibber; 04-20-2017, 10:39 AM.
                          '89 GW
                          360
                          TF727
                          Dana 44's (2.73)
                          Baltic Blue/Sand Interior

                          "Passing everything but Gas Stations"

                          Comment


                          • #14
                            I suppose that's it; I've only ever felt it -- I've never seen it!
                            1990 Grand Wagoneer with HD towing package -- everything works! (for now...)

                            Comment


                            • #15
                              Neal, did that fix it?
                              I just saw your PM today. I've taken some time off from working on the Jeep. Fortunately, I am back at it this weekend. I never found the inline fuse on mine.

                              Hopefully I will gind it the next time I am under there (which may be today). I need to put in new flashers.
                              Last edited by DarkMonohue; 04-30-2017, 01:14 AM.
                              Current Jeep Fleet:
                              1993 Wrangler Sahara (YJ) Stock, 52k
                              1991 Grand Wagoneer - [Black] 4" Lift, 32's, 92k
                              1991 Grand Wagoneer - [Hunter Green] Stock, 60k
                              1991 Grand Wagoneer - [Hunter Green] Restored (for sale)
                              ------------------------------------------------
                              Four Wheel Trends

                              Comment

                              Working...
                              X