Announcement

Collapse
No announcement yet.

Howell TBI / EFI Installation How-To for CARB E.O. #D-452-2

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Howell TBI / EFI Installation How-To for CARB E.O. #D-452-2

    I've looked up and down this forum for good Wagoneer-specific ideas on how to install the Howell TBI kit, but info is rare both here and via google searches.

    Figured I'd create a thread to separately track the Howell install I'm doing on my mechanically stock 88 Grand Wagoneer. This will be an "as I build it" type of thing so final product might change during the course of updating this thread!

    Here's the kit I bought straight from Howell:
    https://howellefi.com/product/k247jp...eer-401-clone/

    The two manuals they link to that are NOT very good references, as they're not Wagoneer-specific, nor of high quality:

    1. https://howellefi.com/wp-content/upl...-1972-1993.pdf
    2. https://howellefi.com/wp-content/upl...ion-Images.pdf

    And off we go...
    --Rob--
    1988 Jeep Grand Wagoneer / Baltic Blue & Tan
    2008 BMW 535xi Wagon / Deep Sea Blue & Tan

    My build thread:
    https://ifsja.org/forums/vb/showthread.php?t=189245
    My Howell TBI Install How-To:
    https://ifsja.org/forums/vb/showthread.php?t=189877

  • #2
    Here's a pic of the kit out of the box.

    From left, top to bottom:
    harness
    brain box
    bag of zip ties, firewall grommet, and other stuff
    bag of base plate, 4 tapered bolts to secure base plate to intake, and 3 bolts to secure throttle body to base.
    throttle body
    fuel filter
    fuel pump
    speed sensor
    O2 sensor
    high pressure EFI fuel hose

    PXL_20210418_160538025 by Robert Stone, on Flickr
    Last edited by MysticRob; 09-10-2021, 08:57 PM.
    --Rob--
    1988 Jeep Grand Wagoneer / Baltic Blue & Tan
    2008 BMW 535xi Wagon / Deep Sea Blue & Tan

    My build thread:
    https://ifsja.org/forums/vb/showthread.php?t=189245
    My Howell TBI Install How-To:
    https://ifsja.org/forums/vb/showthread.php?t=189877

    Comment


    • #3
      Instructions call for removal and/or rerouting of a lot of engine compartment crud, namely the air injection system components, some temp-vacuum sensors, and a ton of vacuum lines.

      Out goes the air cleaner (to be reused later!), carburetor, smog (aka air injection) pump, pump brackets, air injection hoses, air injection manifold piping (metal piping to exhaust manifolds), and mass vacuum hoses from hell:

      GONE!:
      PXL_20210416_225404184 by Robert Stone, on Flickr

      ALSO GONE!:
      PXL_20210416_225414753 by Robert Stone, on Flickr

      ALMOST GONE (DAMMIT)! 2 of the 7 air injection pipe bolts broke inside the manifolds. I got the driver side one out but the passenger side one needed chiseled flat:
      PXL_20210418_180812416 by Robert Stone, on Flickr

      The one I was able to get out next to one that came out easily:
      PXL_20210418_174241942 by Robert Stone, on Flickr

      I'll drill that last bolt out, tap the hole, and insert these 7 manifold plugs from TGW into the manifold holes:
      https://teamgrandwagoneer.com/exhaus...-gw-1974-1991/

      Not seen is the removal of the mechanical fuel pump and hard lines up to the intake area. I yanked all that and used the block off plate and gasket to seal the pump hole on the front of the block. No big deal, not worth a pic.
      Last edited by MysticRob; 09-10-2021, 09:04 PM.
      --Rob--
      1988 Jeep Grand Wagoneer / Baltic Blue & Tan
      2008 BMW 535xi Wagon / Deep Sea Blue & Tan

      My build thread:
      https://ifsja.org/forums/vb/showthread.php?t=189245
      My Howell TBI Install How-To:
      https://ifsja.org/forums/vb/showthread.php?t=189877

      Comment


      • #4
        UPDATED THIS POST TO REFLECT RELOCATED FUEL PUMP AND FILTER!!

        The Howell instructions call for mounting the fuel pump at mid-tank level or lower to avoid potential problems. I decided to take that advice and place the assembly behind the transmission crossmember near the bottom of the frame instead of forward of the crossmember and above the brake hardline. This called for cutting the fuel hardline just before the long straight section close to where the frame is open.

        I used a Ridgid close quarters tubing cutter so I had enough room to cut the lines:
        https://www.amazon.com/gp/product/B0...?ie=UTF8&psc=1

        PXL_20210425_231144214 by Robert Stone, on Flickr

        Here's a better pic of the hardline I cut (above the filter). I wanted to flare the end but there's not enough room to use the kit in there, and the hardline is 5/16" and big enough to allow a nice tight fit once the rubber fuel hose is clamped down on it. I ran the rubber fuel hose in a gentle arc to bring it into the filter, and allow the filter to just sit in the void:
        PXL_20210425_224343143 by Robert Stone, on Flickr

        Good pic showing how low I had to mount the fuel pump so it doesn't sit too high above the fuel tank bottom:
        PXL_20210425_224356759 by Robert Stone, on Flickr

        I had plenty of fuel pump harness to allow moving the pump back from where I originally had it forward of the tranny crossmember (and likely too high). You can just barely see the old screw hole on the very right of the pic that originally held the fuel pump bracket:
        PXL_20210425_235510624 by Robert Stone, on Flickr

        Rolled up quite a bit of the fuel pump harness and hid it in the engine bay under the driver hood hinge:
        PXL_20210425_235442042 by Robert Stone, on Flickr

        Here's how much hardline I cut out. Longer one with rubber hose was the 5/16" feed line I cut near the frame void (near the tank), shorter one is the smaller diameter return line. I was able to pull both lines out thru the front and over the radiator core support with a little wrangling:
        PXL_20210425_235720268 by Robert Stone, on Flickr

        Here's where I cut the return line so I could have room to use the flare kit:
        PXL_20210425_231217358 by Robert Stone, on Flickr

        Since the return line is a smaller diameter, the flare kit gives it a better grip on the fuel hose and to help keep the hose clamp on:
        PXL_20210425_232736742 by Robert Stone, on Flickr
        Last edited by MysticRob; 09-10-2021, 09:13 PM.
        --Rob--
        1988 Jeep Grand Wagoneer / Baltic Blue & Tan
        2008 BMW 535xi Wagon / Deep Sea Blue & Tan

        My build thread:
        https://ifsja.org/forums/vb/showthread.php?t=189245
        My Howell TBI Install How-To:
        https://ifsja.org/forums/vb/showthread.php?t=189877

        Comment


        • #5
          Air injection pump and piping was removed from driver side, and it already looks better. Will repaint the power steering pump, and clean a few things up:
          PXL_20210419_015742539 by Robert Stone, on Flickr

          Pump and brackets will go into a box for storage and eventual reuse when I do the concours restoration (NOT!):
          PXL_20210419_015730972 by Robert Stone, on Flickr
          Last edited by MysticRob; 09-10-2021, 09:18 PM.
          --Rob--
          1988 Jeep Grand Wagoneer / Baltic Blue & Tan
          2008 BMW 535xi Wagon / Deep Sea Blue & Tan

          My build thread:
          https://ifsja.org/forums/vb/showthread.php?t=189245
          My Howell TBI Install How-To:
          https://ifsja.org/forums/vb/showthread.php?t=189877

          Comment


          • #6
            Figure I'll do some touch-ups in the bay so took out the oil fill tube, sanded it down, primer'd, and painted it. Can't help it, it's a disease:
            PXL_20210419_004444769 by Robert Stone, on Flickr
            Last edited by MysticRob; 09-10-2021, 09:18 PM.
            --Rob--
            1988 Jeep Grand Wagoneer / Baltic Blue & Tan
            2008 BMW 535xi Wagon / Deep Sea Blue & Tan

            My build thread:
            https://ifsja.org/forums/vb/showthread.php?t=189245
            My Howell TBI Install How-To:
            https://ifsja.org/forums/vb/showthread.php?t=189877

            Comment


            • #7
              Test fit the TBI base plate and its gasket. The 4 black allen-headed & tapered bolts fit perfectly:
              PXL_20210418_235441481 by Robert Stone, on Flickr

              Also test fit the throttle body and its gasket. 3 bolts with washers secure it to the base plate.
              PXL_20210418_235957788 by Robert Stone, on Flickr
              Last edited by MysticRob; 09-10-2021, 09:20 PM.
              --Rob--
              1988 Jeep Grand Wagoneer / Baltic Blue & Tan
              2008 BMW 535xi Wagon / Deep Sea Blue & Tan

              My build thread:
              https://ifsja.org/forums/vb/showthread.php?t=189245
              My Howell TBI Install How-To:
              https://ifsja.org/forums/vb/showthread.php?t=189877

              Comment


              • #8
                I took the TB and plate off to strip the intake of everything, sand it down, and paint the intake and valve covers with engine semi-gloss rattle can paint:
                PXL_20210423_011743864 by Robert Stone, on Flickr

                Got most of the gunk off and painted everything to include the oil fill tube and A/C compressor bracket:
                PXL_20210423_205943482 by Robert Stone, on Flickr

                Most of the stuff back on and mocked up:
                PXL_20210424_031524868 by Robert Stone, on Flickr
                Last edited by MysticRob; 09-10-2021, 09:22 PM.
                --Rob--
                1988 Jeep Grand Wagoneer / Baltic Blue & Tan
                2008 BMW 535xi Wagon / Deep Sea Blue & Tan

                My build thread:
                https://ifsja.org/forums/vb/showthread.php?t=189245
                My Howell TBI Install How-To:
                https://ifsja.org/forums/vb/showthread.php?t=189877

                Comment


                • #9
                  While mocking everything up I discovered the Howell harness doesn't leave a lot of length between the octopus section that resides inside the dash area to the TPS sensor connection at the very front of the passenger side of the throttle body. Since that octopus section would get stuck, and I need more length, the best way to feed the harness thru the 1.5" firewall hole is to strip the loom off and feed each connector thru individually.

                  There's not a lot of TPS harness length that I can feed thru the firewall to get to that TPS sensor connection. I have a wrench next to the TPS sensor, and tape measure shows maybe 15" max:
                  PXL_20210424_182517473 by Robert Stone, on Flickr

                  From the closest part of the firewall to that sensor there's maybe 13". That doesn't leave much left over to decide where to drill the hole unless you strip the harness and feed it all thru individually:
                  PXL_20210424_182824703 by Robert Stone, on Flickr
                  Last edited by MysticRob; 09-10-2021, 09:24 PM.
                  --Rob--
                  1988 Jeep Grand Wagoneer / Baltic Blue & Tan
                  2008 BMW 535xi Wagon / Deep Sea Blue & Tan

                  My build thread:
                  https://ifsja.org/forums/vb/showthread.php?t=189245
                  My Howell TBI Install How-To:
                  https://ifsja.org/forums/vb/showthread.php?t=189877

                  Comment


                  • #10
                    In order to get up into the dash to mock everything up and figure out where to drill the 1.5" hole into the firewall the entire A/C vent assembly needs to come out, including the 4WD indicator assembly, driver side venting, and large passenger side. Courtesy lights and some other stuff needs disconnected too:
                    PXL_20210424_180748662 by Robert Stone, on Flickr

                    Once the A/C evaporator cover is off, you can lower the assembly down, simultaneously pushing the evap into the dash void, then let the evap hang once the assembly is out. Assemblies off to the side:
                    PXL_20210424_180714460 by Robert Stone, on Flickr

                    The black lower / footwell ducting can be removed by taking out 2 long bolts from the passenger side, one long bolt on the driver side that also has a spacer behind the assembly, and 2 nuts taken off the shafts in the engine compartment:
                    PXL_20210424_180838167 by Robert Stone, on Flickr

                    The holes where the 2 shafts and nuts were:
                    PXL_20210424_180930248 by Robert Stone, on Flickr

                    The view from under the dash is much better now. That black cable is for the heater control, also seen in the pic above, and gives me a much better idea where to drill:
                    PXL_20210424_180854594 by Robert Stone, on Flickr
                    Last edited by MysticRob; 09-10-2021, 09:28 PM.
                    --Rob--
                    1988 Jeep Grand Wagoneer / Baltic Blue & Tan
                    2008 BMW 535xi Wagon / Deep Sea Blue & Tan

                    My build thread:
                    https://ifsja.org/forums/vb/showthread.php?t=189245
                    My Howell TBI Install How-To:
                    https://ifsja.org/forums/vb/showthread.php?t=189877

                    Comment


                    • #11
                      I decided to trace where the black duct ends near where I want to drill to account for the shorter TPS sensor harness, and because the long length of main wiring harness in the cabin will lend itself to going toward the steering wheel, then coming back along the bottom lip of the dash, then up to where I'll have the ECM mounted with velcro along the inside flat part of the dash on the passenger side. The tracing of the black duct gave me a better idea where I should start the hole. I started with a small bit and just drilled a starter hole thru from the inside to the engine bay:
                      PXL_20210425_000234894 by Robert Stone, on Flickr

                      This is the rig I then used to drill using my 90* that only fits a 3/8" shank.
                      Part #s are 49-56-7250 for the 3/8" shank, and 49-56-0713 for the 1.5" hole saw that fits that shank:
                      PXL_20210425_015724893 by Robert Stone, on Flickr

                      I used the starter hole I made earlier as a guide for the hole saw, and from the engine compartment drilled right thru the firewall like butter, being careful to cover the throttle body to avoid metal shards.
                      Last edited by MysticRob; 09-10-2021, 09:30 PM.
                      --Rob--
                      1988 Jeep Grand Wagoneer / Baltic Blue & Tan
                      2008 BMW 535xi Wagon / Deep Sea Blue & Tan

                      My build thread:
                      https://ifsja.org/forums/vb/showthread.php?t=189245
                      My Howell TBI Install How-To:
                      https://ifsja.org/forums/vb/showthread.php?t=189877

                      Comment


                      • #12
                        After drilling the hole and filing down any sharp edges, I discovered the 1.5" hole isn't anywhere close to large enough to fit all the connectors and their separate wiring looms, let alone get that octopus anywhere close enough to get the TPS sensor connected.

                        I decided to take all the tape off the octopus and strip the separate wiring looms back, then feed them all separately thru the hole. This relay had to go first since it was too big to get thru with anything else already thru the hole. I took off the cover, trimmed some of the plastic off the edges, and finally wedged it thru the hole with a little help from a flat punch and hammer :
                        PXL_20210425_021033470 by Robert Stone, on Flickr

                        With all the looms stripped back I was able to fit all the connectors thru much easier, being careful not to damage any wiring. This had to be done or there was no way to fit everything thru the hole. This also allowed me to yank much more of the main harness into the engine bay to get that TPS sensor connector closer to the TB (behold the exposed wiring octopus):
                        PXL_20210425_032747636 by Robert Stone, on Flickr

                        After I re-loomed all the connectors and taped the octopus back up in the engine compartment, I was able to wedge the grommet in, then organized the connectors. You can see the octopus now sticking thru the firewall just over the main harness that goes across the rear of the firewall.

                        I was able to terminate everything on the intake, including the TPS sensor with a couple more inches to spare, plus zip tie the fuel pump loom across the firewall under the main harness and drop it down between the main harness and brake booster. I also fed the coolant sensor and the 2 injector connectors under the A/C bracket to hide them and keep it clean. The injector connectors can be fed into a built-in void on the TB to clear the inside of the air cleaner gasket and air cleaner assembly when it finally goes back on:
                        PXL_20210425_051914470 by Robert Stone, on Flickr
                        Last edited by MysticRob; 09-10-2021, 09:34 PM.
                        --Rob--
                        1988 Jeep Grand Wagoneer / Baltic Blue & Tan
                        2008 BMW 535xi Wagon / Deep Sea Blue & Tan

                        My build thread:
                        https://ifsja.org/forums/vb/showthread.php?t=189245
                        My Howell TBI Install How-To:
                        https://ifsja.org/forums/vb/showthread.php?t=189877

                        Comment


                        • #13
                          Working on connections today. Most of it is straight forward, but had some concerns about harness length.

                          Left to right here, close-ups of the Idle Air Control sensor, TPS sensor, and 2 fuel injector connectors. Far left under a coolant hose is the MAP sensor I was told to cut the hose for to about 2". This type of MAP sensor doesn't need to be mounted downward according to the Howell tech I spoke to:
                          PXL_20210425_181439509 by Robert Stone, on Flickr

                          Direct battery power here. Plenty of harness to connect:
                          PXL_20210425_184807983 by Robert Stone, on Flickr

                          Small connector for starter solenoid. Was able to route it around the fuel vent lines to keep it away from the passenger side exhaust manifold, but not much length left:
                          PXL_20210425_181355694 by Robert Stone, on Flickr

                          Fuel pump relay (I think). I just drilled a small hole and screwed it to the firewall near the octopus to keep it looking clean:
                          PXL_20210425_181420422 by Robert Stone, on Flickr

                          I was told the speedo sensor can leak so used a bit of sealant around the potential exit:
                          PXL_20210425_182959241 by Robert Stone, on Flickr

                          Speedo sensor now mounted. Not much length to work with, as the harness connector was barely peaking out from the top of the transfer case. The sensor had enough length to reach that connector though:
                          PXL_20210425_184607665 by Robert Stone, on Flickr
                          Last edited by MysticRob; 09-10-2021, 09:37 PM.
                          --Rob--
                          1988 Jeep Grand Wagoneer / Baltic Blue & Tan
                          2008 BMW 535xi Wagon / Deep Sea Blue & Tan

                          My build thread:
                          https://ifsja.org/forums/vb/showthread.php?t=189245
                          My Howell TBI Install How-To:
                          https://ifsja.org/forums/vb/showthread.php?t=189877

                          Comment


                          • #14
                            Drilled a couple holes and screwed the new harness fuse block in to the right of the factory location:
                            PXL_20210428_002808220 by Robert Stone, on Flickr

                            Still need to terminate the switched 12V ignition power wire. Will investigate that and where to terminate my sunroof power wire too:
                            PXL_20210428_003446891 by Robert Stone, on Flickr
                            Last edited by MysticRob; 09-10-2021, 09:39 PM.
                            --Rob--
                            1988 Jeep Grand Wagoneer / Baltic Blue & Tan
                            2008 BMW 535xi Wagon / Deep Sea Blue & Tan

                            My build thread:
                            https://ifsja.org/forums/vb/showthread.php?t=189245
                            My Howell TBI Install How-To:
                            https://ifsja.org/forums/vb/showthread.php?t=189877

                            Comment


                            • #15
                              Got the 7 exhaust manifold plugs from TGW so put 6 of them in. Also drilled out that 1 problem child bolt and will tap it when I get home from work today:
                              PXL_20210429_000312568 by Robert Stone, on Flickr
                              Last edited by MysticRob; 09-10-2021, 09:39 PM.
                              --Rob--
                              1988 Jeep Grand Wagoneer / Baltic Blue & Tan
                              2008 BMW 535xi Wagon / Deep Sea Blue & Tan

                              My build thread:
                              https://ifsja.org/forums/vb/showthread.php?t=189245
                              My Howell TBI Install How-To:
                              https://ifsja.org/forums/vb/showthread.php?t=189877

                              Comment

                              Working...
                              X