International Full Size Jeep Association
Home Forums Reader's Rigs Tech Library Trail Stories FSJ-List
International Full Size Jeep Association  

Go Back   International Full Size Jeep Association > Tire Kickin' > Fuel Injection

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 10-28-2013, 07:48 PM
ThisGuyUKnow's Avatar
ThisGuyUKnow ThisGuyUKnow is offline
350 Buick
 
Join Date: Mar 25, 2008
Location: Macomb,Il
Posts: 1,460
Junkyard TPI Finally Lives!

So maybe I can't completely call this a junkyard tpi because it requires a non stock modified intake.

I bought a holley street dominator off rawdave several years ago. He had modded the intake to take fuel rails and injectors from a corvette and moddified a TBI to act as a dry Throttle body. It actually came with a wiring harness and ecm as from CustomEFIs as well but that was missing some of the labels. I contacted the CustomEFIs dude and he offered to help me out by relabelling the harness if I sent it to him. I did and that was the last i saw of the harness.

So I swallowed my losses and found someone parting out a 91 vette got the wiring harness off him and that is as far as the project went for about 3 years.

Well I finally felt I had the wiring expertise to sort through the harness and thin it out properly. I purchased a Cj7 with a rebuilt (but not running) 360 in it and started the process. Today after a weekend of trying it finally got it to idle on its own power!

Its doesnt sound super healthy but I also do not have coolant, down pipes, belts, or some of the sensors properly hooked up yet. Still its better than nothing.
__________________
'85 CJ7 Laredo- Rebuilt 360, Tuned Port Injection, T-176, D300, W/T 3.31 w/Trac Loc, 31x10.5x15 BFGs
Reply With Quote
  #2  
Old 10-30-2013, 12:11 AM
REDONE's Avatar
REDONE REDONE is offline
Bleedin' Gasoline
 
Join Date: Aug 19, 2002
Location: Golden, CO
Posts: 1,752
I won't say it sounds like you've won, but I would say it sounds like you're up by 7 at the end of the first!

TPI is awesome!
__________________
2012 Winner of the Prestigious Ouray Cast Iron Butt Award
79 J-10 - The Money Badger!
304/T18/D20/D44s
What's been did:
Holley 4160/Ede' S.P.2.P.
MSD Streetfire based TFI
Custom-hack gauge cluster
Razor swap
Fancy exhaust (Thrush Muffler)
2 knob tape deck!
3" homebuilt lift
Half a hillbilly paint job
Reply With Quote
  #3  
Old 10-30-2013, 11:28 AM
ThisGuyUKnow's Avatar
ThisGuyUKnow ThisGuyUKnow is offline
350 Buick
 
Join Date: Mar 25, 2008
Location: Macomb,Il
Posts: 1,460
Quote:
Originally Posted by REDONE
I won't say it sounds like you've won, but I would say it sounds like you're up by 7 at the end of the first!

TPI is awesome!
yep got a ways to go. I hope to be tuning it within the next few weekends
__________________
'85 CJ7 Laredo- Rebuilt 360, Tuned Port Injection, T-176, D300, W/T 3.31 w/Trac Loc, 31x10.5x15 BFGs
Reply With Quote
  #4  
Old 10-31-2013, 09:47 AM
Billygoat's Avatar
Billygoat Billygoat is offline
Bleedin' Gasoline
 
Join Date: Mar 16, 2004
Location: Southwest Wisconsin
Posts: 2,493
cool - glad you got it going
Reply With Quote
  #5  
Old 10-31-2013, 12:42 PM
ThisGuyUKnow's Avatar
ThisGuyUKnow ThisGuyUKnow is offline
350 Buick
 
Join Date: Mar 25, 2008
Location: Macomb,Il
Posts: 1,460
Quote:
Originally Posted by Billygoat
cool - glad you got it going

Yeah turned out that modding the dist for esc wasn't as confusing as I thought it would be, so I guess its good our sale fell through
__________________
'85 CJ7 Laredo- Rebuilt 360, Tuned Port Injection, T-176, D300, W/T 3.31 w/Trac Loc, 31x10.5x15 BFGs
Reply With Quote
  #6  
Old 11-01-2013, 12:01 PM
PlasticBoob's Avatar
PlasticBoob PlasticBoob is offline
All Makes Combined
 
Join Date: Jun 30, 2003
Location: Long Beach, CA
Posts: 4,007
Woo, congrats! Keep us updated, I love seeing others making progress with different types of EFI on these engines.
__________________
Rob
1974 Cherokee S, fuel injected 401, Trans-am Red, Aussie locker 'out back'
Click for video

The Southern California FSJ forum
Reply With Quote
  #7  
Old 01-02-2014, 08:04 AM
jeepin87's Avatar
jeepin87 jeepin87 is offline
232 I6
 
Join Date: Nov 27, 2007
Location: Alamogordo, NM
Posts: 70
Any updated info? My dad adapted TPI to his 360 years ago but is just now getting around to tune it in better. He had is running good with the stock injectors but it would run out of fuel. Now, after a tub swap (CJ7) and an injector swap it doesn't run that great. He is going to swap back to the stock injectors and see if that will at least get the engine running like it did. I'm interested to see how yours turns out, maybe share some tuning info.

He machined some adapters and used a TPI intake, moved the oil fill to the back. I'll have to get some pics, its pretty slick.
__________________
Lots of rigs, parts, and lost knowledge.
Reply With Quote
  #8  
Old 01-02-2014, 11:22 PM
ThisGuyUKnow's Avatar
ThisGuyUKnow ThisGuyUKnow is offline
350 Buick
 
Join Date: Mar 25, 2008
Location: Macomb,Il
Posts: 1,460
Quote:
Originally Posted by jeepin87
Any updated info? My dad adapted TPI to his 360 years ago but is just now getting around to tune it in better. He had is running good with the stock injectors but it would run out of fuel. Now, after a tub swap (CJ7) and an injector swap it doesn't run that great. He is going to swap back to the stock injectors and see if that will at least get the engine running like it did. I'm interested to see how yours turns out, maybe share some tuning info.

He machined some adapters and used a TPI intake, moved the oil fill to the back. I'll have to get some pics, its pretty slick.

Well I have no good news on the swap.

I had it running when I posted this. My first set of problems was when I locked out the vacuum and mechanical advance stuff. I couldnt get the engine to start and it kept back firing. I eventually Set the balancer line to 10 BTDC and it started. When I put the timing light on it it showed just slightly ATDC. SO I realized when I locked the mechanical parts I accidentally added a little static retard to the dizzy. I set the timing to 6BTDC (with the timing wire unhooked at the ecm) because that is what all the vette guys say they set their 350s to. And the engine would start up no problem and drive around the yard. SO I made this thread while pounded beers in celebration.

At that point I only had headers on the engine no down pipe or y, since the exhaust wasnt installed I had no o2 sensor hooked up, and the vss was not hooked up either, I had the serpentine (bulltear) hooked up and tight, hydraboost installed.

I started it occasionally just for grins and giggles for about a month but didnt let it run long because I didnt have the exhaust pipe hooked up. So I bought one of those bumper mounted tow bars and towed it up to the exhaust shop. I thought I had put the tranny and the d300 in nuetral but when I got to the shop I discovered that the D300 was still in drive (only towed it 8 miles so hope its ok). I unhooked and started it up no issues and drove it accross the lot (maybe about 100 feet?) with no issues aside from the missing exhaust.

Flash forward a day or two I call to check on the progress and the shop says it wouldnt start so they would have to push it into the shop. This I thought was odd because i had it running fine and at least driveable. But I thought nothing of it and went to pick up the cj a few days later when it was done.

When I went to pick it up he said they did drive it out of the shop but it ran really rough. I didnt think much of this cause I knew there would be some tuning involved and it didnt run silky smooth prior, I just assumed it was driving like it was before I dropped it off. Well unfortunately I got it started and it ran like straight behind hole. Shaking, felt like no power, stalling out violently when you tried to let off the clutch. In the comments he wrote "Seems like its missing on a cylinder"

Fast forward to getting it home. I unhook and start it, try to drive it up the steep driveway (not enough room to tow it all the way up) and its still running just as bad as at the shop and keeps stalling out. Eventually the bat dies on me due to all the starts so I charge it over night to try again. The next morning it starts it idles maybe a minute then just dies, now it will not start at all. You can crank and crank but it doesnt get any combustion at all.

So I started looking at all my bases. First I checked the obvious, fuel. I thought maybe that the anti theft bypass wasnt working, but i dug it out from under the dash and the LEDS were working to indicate it was on. So I tried adding starter fluid to the TB to bypass the injectors just incase they really werent firing and still no combustion. So I checked spark and I am getting spark at the wires. still no combustion. So i thought maybe my dizz got loose and I lost y timing so I reset that to 10 BTDC. Still nothing.

I am simply stumped. The only thing I didnt check was the plugs them selves but all 8 cant be fouled I should be getting some combustion in at least a cylinder or 2. I have fuel, I have spark, and I know I have static timing cause I unhooked the computers EST wire.

Its very frustrating right now because I dont have a garage so I am subject to the elements when I work on the jeep. Not to mention I cant get it up to the flat parking spot right next to my porch which sucks. Im not sure what the heck I am missing and this project is so unique I am kinda on my own when it comes to troubleshooting it. I have been traveling for the holidays over the last two weeks so I have had a breather from it. I was kinda hoping that after taking my mind off it for so long i would have an epiphany and the answer would come to me but alas I am heading back stuck sleeping in the Detroit air terminal due to weather issues and still have no idea what the issue may be.
__________________
'85 CJ7 Laredo- Rebuilt 360, Tuned Port Injection, T-176, D300, W/T 3.31 w/Trac Loc, 31x10.5x15 BFGs
Reply With Quote
  #9  
Old 02-02-2014, 07:46 PM
ThisGuyUKnow's Avatar
ThisGuyUKnow ThisGuyUKnow is offline
350 Buick
 
Join Date: Mar 25, 2008
Location: Macomb,Il
Posts: 1,460
Quote:
Originally Posted by jeepin87
Any updated info? My dad adapted TPI to his 360 years ago but is just now getting around to tune it in better. He had is running good with the stock injectors but it would run out of fuel. Now, after a tub swap (CJ7) and an injector swap it doesn't run that great. He is going to swap back to the stock injectors and see if that will at least get the engine running like it did. I'm interested to see how yours turns out, maybe share some tuning info.

He machined some adapters and used a TPI intake, moved the oil fill to the back. I'll have to get some pics, its pretty slick.

My project is back on track. I finally got it to fire up today.. I am not sure what malfunctioned originally but after reseting the timing a thousand times and and replacing alot of sensors and such It finally turned out that I had advanced the timing too far.

When you say your dad did an injector swap do you mean he wen to a different rate injector? If that is the case then it is very likely that he needs to change some parameters in the ECM. If the ecm has the wrong rates it will not be able to meter the fuel.
__________________
'85 CJ7 Laredo- Rebuilt 360, Tuned Port Injection, T-176, D300, W/T 3.31 w/Trac Loc, 31x10.5x15 BFGs
Reply With Quote
  #10  
Old 02-17-2014, 11:11 PM
ThisGuyUKnow's Avatar
ThisGuyUKnow ThisGuyUKnow is offline
350 Buick
 
Join Date: Mar 25, 2008
Location: Macomb,Il
Posts: 1,460
I seem to be having alot of trouble with the timing. When I set the timing via hand, it seems to put me almost 90 degrees out from where it should be. For any of you guys who are further along in chevy hybrid systems, is it possible that I may have locked a retard or advance into my dist in the process of locking it out. (its the same process as the TBI kits).

Here are some more pics of the TPI setup. The Vette donor lacked a true pdc, apparently the rlys are just strewn throughout the engine and the cab, so I used a cheap fuse center and stackable rlys I found on ebay. I think in a few weeks when the snow clears up a bit I am going to rob a PDC off a 4.0 cherk at the boneyard (why a 4.0? Just because it could be any pdc) and do some major rewiring to move all the relays fuses and stuff into one spot.
this is the mess I started with notice the gas can, that is incase I get really frustrated with the jeep project. Im surprised I haven't burned the jeep to the ground yet to be honest.


The ball of wire was the every growing pile of unused wire


All ECM wires isolated


Wires labeled and bundled pas on function (IE grounds, power, sensors, aldl)


Generic pic of stuff coming out of the factory harness, looks like the ICM from the driver fender in this pic


Intake removed



Intake Dropped on, Didnt do enough research or fully appreciate how much of a gap would be between the intake and the block so I had to pull it off and build up a good rtv seal. Also a note, I could not get the dange Torque wrench in to most of the bolts. Luckily I realized that the open of of a 1/2 inch wrench would fit the 1/2 torque wrench, not sure how other people solve this issue.




Crazy engine spaghetti, I swear I know where everything goes!


Engine Spaghetti Cleaned up


HEI modded for ESC


Relay center and Fuse block. This I am going to try and do better with a 4.0 donor but it will do for now. There is are 2 fan rlys, fuel pump rly, and 2 unused rlys that I added just incase I wanted to do the relay bypass for the head lamps.


The configuration all together, I couldnt find a post that would work with the modified TBI body so I eventually just grabbed a generic air filter from the parts store and drilled a hole through it to fit the post. Not the cleanest solution but it will do for now.

__________________
'85 CJ7 Laredo- Rebuilt 360, Tuned Port Injection, T-176, D300, W/T 3.31 w/Trac Loc, 31x10.5x15 BFGs

Last edited by ThisGuyUKnow : 02-17-2014 at 11:17 PM.
Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Junkyard TBI setup $$$$ blake5179 Fuel Injection 12 03-13-2011 09:34 AM
Finally got a speedometer! The_Turd General FSJ Tech 0 01-30-2010 12:48 PM
Junkyard Replacement Rads JeepMods General FSJ Discussion 11 10-12-2009 10:41 AM
Finally got a 401 Ghinmi General FSJ Tech 15 12-19-2006 05:52 PM
Finally got my 4x4 low!!!! Thanks for the help! gmarblestone General FSJ Tech 1 12-11-2006 11:36 AM


All times are GMT -6. The time now is 06:30 AM.


Powered by vBulletin Version 3.5.4
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
corner corner